Update di sicurezza Prestashop – Aggiorna ora il tuo shop

E’ di questi giorni la notizia di un potenziale problema di sicurezza nel tool di generazione password incluso in Prestashop.

Il Prestashop Team si è mosso prontamente invitando gli utenti ad aggiornare le proprie installazioni e rilasciando un articolo completo a riguardo che potete consultare qui


Sono state inoltre rilasciate le patch per le ultime branch di ogni versione (1.4 , 1.5 , 1.6) assieme ad un modulo ideato per applicare questa e future eventuali patch in maniera trasparente ed una guida per applicare autonomamente le patch modificando i files di classi e controller coinvolti.

Bug Prestashop security release

Segnaliamo che molti utenti hanno riscontrato problemi con il modulo, in quanto richiede configurazioni server particolari (ad esempio la possibilità di eseguire comandi shell tramite PHP, opzione non supportata da diversi hosting).

Tutte le versioni sono coinvolte dal problema ad eccezione della nuova 1.6.1.0 e di Prestashop Cloud.

A chi non potesse aggiornare il proprio sito a causa di modifiche varie,  rendiamo disponibili i files patchati per la versione 1.6.0.9 (una delle 1.6 più diffuse) utilizzando la guida manuale offerta dal Prestashop Team.

Se desideri verificare il tuo sito o valutare un aggiornamento inviaci una mail a info@prestalia.it

 

 

Commenti

Commenti

 

Trackback dal tuo sito.

Lascia un commento